Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

nge(4D)

Name

nge - Gigabit Ethernet driver for Nvidia Gigabit family of network interface controllers

Synopsis

/dev/nge

Description

The nge Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD v3-based STREAMS driver supporting the Data Link Provider Interface dlpi(4P), on Nvidia ck8-04/mcp55/mcp51 Gigabit Ethernet controllers. The controller is a Mac chipset that works with PHY functions and provides three-speed (copper) Ethernet operation on the RJ-45 connectors.

The nge driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support, and error recovery and reporting.

The nge driver and hardware support auto-negotiation, a protocol specified by the 1000 Base-T standard. Auto-negotiation allows each device to advertise its capabilities and discover those of its peer (link partner). The highest common denominator supported by both link partners is automatically selected, yielding the greatest available throughput while requiring no manual configuration. The nge driver also allows you to configure the advertised capabilities to less than the maximum (where the full speed of the interface is not required), or to force a specific mode of operation, irrespective of the link partner's advertised capabilities.

APPLICATION PROGRAMMING INTERFACE

The cloning, character-special device /dev/nge is used to access all nge devices.

The nge driver is dependent on /kernel/misc/mac, a loadable kernel module that provides the DLPI and STREAMS functionality required of a LAN driver. See gld(4D) for more details on supported primitives.

You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.

The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ are as follows:

  • Maximum SDU (with jumbo frame) is 9000. (ETHERMTU - defined in <sys/ethernet.h>.)

  • Minimum SDU is 68.

  • DSLAP address length is 8 bytes.

  • MAC type is DL_ETHER.

  • SAP length value is -2 meaning the physical address component is followed immediately by a 2-byte sap component within the DLSAP address.

  • Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).

Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular Service Access Point (SAP) with the stream.

CONFIGURATION

By default, the nge driver performs auto-negotiation to select the link speed and mode. Link speed and mode can be any one of the following, (as described in the IEEE803.2 standard):

1000 Mbps, full-duplex.

1000 Mbps, half-duplex.

100 Mbps, full-duplex.

100 Mbps, half-duplex.

10 Mbps, full-duplex.

10 Mbps, half-duplex.

The auto-negotiation protocol automatically selects speed (1000 Mbps, 100 Mbps, or 10 Mbps) and operation mode (full-duplex or half-duplex) as the highest common denominator supported by both link partners. Because the nge device supports all modes, the effect is to select the highest throughput mode supported by the other device.

Alternatively, you can set the capabilities advertised by the nge device using dladm(8). The driver supports a number of parameters whose names begin with enable (see below). Each of these parameters contains a boolean value that determines whether the device advertises that mode of operation. If en_autoneg_cap is set to 0, the driver forces the mode of operation selected by the first non-zero parameter in priority order as listed below:

(highest priority/greatest throughput)
          en_1000fdx_cap         1000Mbps full duplex
          en_1000hdx_cap         1000Mbps half duplex
          en_100fdx_cap          100Mbps full duplex
          en_100hdx_cap          100Mbps half duplex
          en_10fdx_cap           10Mbps full duplex
          en_10hdx_cap           10Mbps half duplex
                                (lowest priority/least throughput)

For example, to prevent the device 'nge2' from advertising gigabit capabilities, enter (as super-user):


# dladm set-linkprop -p en_1000fdx_cap=0 nge2

All capabilities default to enabled. Note that changing any capability parameter causes the link to go down while the link partners renegotiate the link speed/duplex using the newly changed capabilities.

You can obtain the current parameters settings using dladm show-linkprop. In addition, the driver exports the current state, speed, duplex setting and working mode of the link via kstat parameters (which are read only and can not be changed). For example, to check link state of device nge0:


# dladm show-linkprop -p state nge1
       LINK         PROPERTY        VALUE      DEFAULT     POSSIBLE
       nge1         state           up         up          up,down
       # dladm show-linkprop -p speed nge0
       LINK         PROPERTY        VALUE      DEFAULT     POSSIBLE
       nge1         speed           100          --        10,100,1000
       # dladm show-linkprop -p duplex nge1
       LINK         PROPERTY        VALUE      DEFAULT     POSSIBLE
       nge1         duplex          full       full        half,full
       # dladm show-linkprop -p flowctrl nge1
       LINK         PROPERTY        VALUE      DEFAULT     POSSIBLE
       nge1         flowctrl        no         bi          no,tx,rx,bi

The output above indicates that the link is up and running at 100Mbps full-duplex with its rx/tx direction pause capability. In addition, the driver exports its working mode by loop_mode. If it is set to 0, the loopback mode is disabled.

Only MCP55/CK804 chipsets accept the Maximum MTU upper to 9000 bytes. Use default_mtu to set in /kernel/drv/nge.conf file, then reboot to make it available. The default MTU value is 1500. For MCP55/CK804 chipsets, nge provides one option of minimal memory usage. Use minimal-memory-usage = 1 in the /kernel/drv/nge.conf file, then reboot to make it available. With this option, the nge driver can reduce memory usage by two thirds. Setting minimal-memory-usage = 1 does not take effect if MTU is increased above the default value. To avoid problems, do not set the minimal-memory-usage and default_mtu options together in the nge.conf file.

Files

/dev/nge

nge special character device.

/kernel/drv/amd64/nge

64-bit ELF Kernel module (x86).

/kernel/drv/nge.conf

Driver configuration file.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
x86

See Also

gld(4D), streamio(4I), dlpi(4P), attributes(7), dladm(8), ndd(8)

Writing Device Drivers in Oracle Solaris 11.4

STREAMS Programming Guide