Go to main content

man pages section 4: Device and Network Interfaces

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ixgb(4D)

Name

ixgb - SUNWixgb, 10 Gigabit Ethernet driver for Intel 82597ex controllers and Sun Ethernet PCI-X Adapter (X5544A-4) adapters.

Synopsis

/dev/ixgb 

Description

The ixgb 10 Gigabit Ethernet driver is a multi-threaded, loadable, clonable, GLD-based STREAMS driver supporting the Data Link Provider Interface, DLPI on Intel 82597ex 10 Gigabit Ethernet controllers and Sun 10 Gigabit Ethernet PCI-X Adapter (X5544A-4) on x86 Platforms. The Intel 10G controller incorporates both MAC and PHY functions and provides 10G (fiber) Ethernet operation on the SR and LR connectors. The Sun 10 Gigabit Ethernet PCI-X Adapter (X5544A-4) is a 133 MHz PCI-X 10 Gigabit Ethernet card utilizing the Intel 82597EX PCI-X MAC controller with XFP-based 10GigE optics.

The ixgb driver functions include controller initialization, frame transmit and receive, promiscuous and multicast support and error recovery and reporting.

The ixgb driver and hardware support auto-negotiation, a protocol specified by the IEEE 802.3ae specification.

Configuration

The following ixgb.conf configuration option is supported:

default_mtu

Upper limit on the maximum MTU size the driver allows. Intel 82597EX controller allows the configuration of jumbo frames. To configure jumbo frame, use ifconfig(8). Use ifconfig with the adapter instance and the mtu argument (for example: ifconfig ixgb0 mtu 9000) to configure the adapter for the maximum allowable jumbo frame size. Allowed range is 1500 - 9000.

APPLICATION PROGRAMMING INTERFACE

The cloning character-special device /dev/ixgb is used to access all Intel 10G controllers and Sun 10 Gigabit Ethernet PCI-X adapters (X5544A-4) installed within the system

The ixgb driver is managed by the dladm(8) command line utility, which allows VLANs to be defined on top of ixgb instances and for ixgb instances to be aggregated. See dladm(8) for more details.

You must send an explicit DL_ATTACH_REQ message to associate the opened stream with a particular device (PPA). The PPA ID is interpreted as an unsigned integer data type and indicates the corresponding device instance (unit) number. The driver returns an error (DL_ERROR_ACK) if the PPA field value does not correspond to a valid device instance number for the system. The device is initialized on first attach and de-initialized (stopped) at last detach.

The values returned by the driver in the DL_INFO_ACK primitive in response to the DL_INFO_REQ are:

  • Maximum SDU is 9000 (ETHERMTU, as defined in <sys/ethernet.h>).

  • Minimum SDU is 0.

  • DLSAP address length is 8.

  • MAC type is DL_ETHER.

  • SAP length value is −2 meaning the physical address component is followed immediately by a 2 byte SAP component within the DLSAP address.

  • Broadcast address value is Ethernet/IEEE broadcast address (FF:FF:FF:FF:FF:FF).

Once in the DL_ATTACHED state, you must send a DL_BIND_REQ to associate a particular Service Access Point (SAP) with the stream.

By default, the ixgb driver performs auto-negotiation to select the 10G link speed.

Files

/dev/ixgb

Special character device.

/kernel/drv/sparcv9/ixgb

Driver binary.

/kernel/drv/amd64/ixgb

64-bit kernel module (x86 only).

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
x86

See Also

gld(4D), streamio(4I), dlpi(4P), attributes(7), dladm(8), ifconfig(8)

IEEE 802.3ae Specification, IEEE - 2002

https://standards.ieee.org/standard/802_3ae-2002.html

Sun 10 Gigabit Ethernet PCI-X Adapter (X5544A-4) Driver Installation Notes for Solaris

Writing Device Drivers in Oracle Solaris 11.4

STREAMS Programming Guide