man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

ddi_regs_map_free(9F)

Name

ddi_regs_map_free - free a previously mapped register address space

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h>

void ddi_regs_map_free(ddi_acc_handle_t *handle);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

handle

Pointer to a data access handle previously allocated by a call to a setup routine such as ddi_regs_map_setup(9F).

Description

ddi_regs_map_free () frees the mapping represented by the data access handle handle. This function is provided for drivers preparing to detach themselves from the system, allowing them to release allocated system resources represented in the handle.

Context

ddi_regs_map_free() must be called from user or kernel context.

Attributes

See attributes(5) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
PCI Local Bus, SBus, ISA

See also

attributes(5), ddi_regs_map_setup(9F)

Writing Device Drivers for Oracle Solaris 11.2