man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

putnext(9F)

Name

putnext - send a message to the next queue

Synopsis

#include <sys/stream.h>
#include <sys/ddi.h>

void putnext(queue_t *q, mblk_t *mp);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the queue from which the message mp will be sent.

mp

Message to be passed.

Description

The putnext() function is used to pass a message to the put(9E) routine of the next queue in the stream.

Return Values

None.

Context

The putnext() function can be called from user, interrupt, or kernel context.

Examples

See allocb(9F) for an example of using putnext().

See also

put(9E), allocb(9F), put(9F), qprocson(9F)

Writing Device Drivers for Oracle Solaris 11.2

STREAMS Programming Guide

Notes

The put() and putnext() functions should be called only after qprocson() is finished.