man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: July 2014
 
 

rd(9F)

Name

RD, rd - get pointer to the read queue

Synopsis

#include <sys/stream.h>
#include <sys/ddi.h>

queue_t *RD(queue_t *q);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

q

Pointer to the write queue whose read queue is to be returned.

Description

The RD() function accepts a write queue pointer as an argument and returns a pointer to the read queue of the same module.

CAUTION: Make sure the argument to this function is a pointer to a write queue. RD() will not check for queue type, and a system panic could result if it is not the right type.

Return Values

The pointer to the read queue.

Context

The RD() function can be called from user, interrupt, or kernel context.

Examples

Example 1 Function page reference

See the qreply(9F) function page for an example of RD().

See also

qreply(9F), WR(9F)

Writing Device Drivers for Oracle Solaris 11.2

STREAMS Programming Guide