|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- command summary from process accounting records
/usr/lib/acct/acctcms [-a [-o] [-p]] [-c] [-j] [-n] [-s] [-t] filename...
acctcms reads one or more filenames, normally in the form described in acct.h(3HEAD). It adds all records for processes that executed identically named commands, sorts them, and writes them to the standard output, normally using an internal summary format.
Print output in ASCII rather than in the internal summary format. The output includes command name, number of times executed, total kcore-minutes, total CPU minutes, total real minutes, mean size (in K), mean CPU minutes per invocation, "hog factor,” characters transferred, and blocks read and written, as in acctcom(1). Output is normally sorted by total kcore-minutes.
Use the following options only with the -a option:
Output a (non-prime) offshift-time-only command summary.
Output a prime-time-only command summary.
When -o and -p are used together, a combination prime-time and non-prime-time report is produced. All the output summaries are total usage except number of times executed, CPU minutes, and real minutes, which are split into prime and non-prime.
Sort by total CPU time, rather than total kcore-minutes.
Combine all commands invoked only once under "***other".
Sort by number of command invocations.
Any file names encountered hereafter are already in internal summary format.
Process all records as total accounting records. The default internal summary format splits each field into prime and non-prime-time parts. This option combines the prime and non-prime time parts into a single field that is the total of both, and provides upward compatibility with old style acctcms internal summary format records.
Example 1 Using the acctcms command.
A typical sequence for performing daily command accounting and for maintaining a running total is:
example% acctcms filename ... > today example% cp total previoustotal example% acctcms -s today previoustotal > total example% acctcms -a -s today
See attributes(5) for descriptions of the following attributes:
Unpredictable output results if -t is used on new style internal summary format files, or if it is not used with old style internal summary format files.