|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- start the LP print service
lpsched [-f num_filters] [-n num_notifiers] [-p fd_limit] [-r reserved_fds]
The lpsched command starts or restarts the LP print service.
The lpshut command stops the LP print service. Printers that are restarted using lpsched reprint (in their entirety) print requests that were stopped by lpshut. See lpshut(1M).
It is recommended that you start and stop the LP print service using svcadm(1M). See NOTES.
The following options are supported:
Specifies the number of concurrent slow filters that may be run on a print server. A default value of 1 is used if none is specified. Depending on server configuration, a value of 1 may cause printers to remain idle while there are jobs queued to them.
Specifies the number of concurrent notification processes that can run on a print server. A default value of 1 is used when none is specified.
Specifies the file descriptor resource limit for the lpsched process. A default value of 4096 is used if none is specified. On extremely large and active print servers, it may be necessary to increase this value.
Specifies the number of file descriptors that the scheduler reserves for internal communications under heavy load. A default value of 2 is used when none is specified. It should not be necessary to modify this value unless instructed to do so when troubleshooting problems under high load.
The following exit values are returned:
An error occurred.
LP print queue.
See attributes(5) for descriptions of the following attributes:
The lpsched service is managed by the service management facility, smf(5), under the service identifier: