|Skip Navigation Links|
|Exit Print View|
|man pages section 1M: System Administration Commands Oracle Solaris 11 Express 11/10|
- list file names and statistics for a file system
ff [-F FSType] [-V] [generic_options] [-o specific_options] special...
ff prints the pathnames and inode numbers of files in the file system which resides on the special device special. Other information about the files may be printed using options described below. Selection criteria may be used to instruct ff to only print information for certain files. If no selection criteria are specified, information for all files considered will be printed (the default); the -i option may be used to limit files to those whose inodes are specified.
Output is sorted in ascending inode number order. The default line produced by ff is:
The maximum information the command will provide is:
path-name i-number size uid
Specify the FSType on which to operate. The FSType should either be specified here or be determinable from /etc/vfstab by matching the special with an entry in the table, or by consulting /etc/default/fs.
Echo the complete command line, but do not execute the command. The command line is generated by using the options and arguments provided by the user and adding to them information derived from /etc/vfstab. This option may be used to verify and validate the command line.
Options that are supported by most FSType-specific modules of the command. The following options are available:
Do not print the i-node number after each path name.
Generate a supplementary list of all path names for multiply-linked files.
The specified prefix will be added to each generated path name. The default is `.' (dot).
Print the file size, in bytes, after each path name.
Print the owner's login name after each path name.
Select if the file has been accessed in n days.
Select if the file has been written or created in n days.
Select if file's status has been changed in n days.
Select if the file has been modified more recently than the argument file.
Generate names for only those i-nodes specified in i-node-list. i-node-list is a list of numbers separated by commas (with no intervening spaces).
Specify FSType-specific options in a comma separated (without spaces) list of suboptions and keyword-attribute pairs for interpretation by the FSType-specific module of the command.
A special device.
See largefile(5) for the description of the behavior of ff when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
default local file system type. Default values can be set for the following flags in /etc/default/fs. For example: LOCAL=ufs
The default partition for a command if no FSType is specified.
list of default parameters for each file system
See attributes(5) for descriptions of the following attributes:
This command may not be supported for all FSTypes.
The -a, -m, and -c flags examine the st_atime, st_mtime, and st_ctime fields of the stat structure respectively. (See stat(2).)