Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

audio_dev_warn(9F)

Name

audio_dev_warn - log a warning message for an audio device

Synopsis

#include <sys/audio/audio_driver.h>

void audio_dev_warn(audio_dev_t *adev, const char *fmt, ...);

Parameters

adev

pointer to an audio device allocated with audio_dev_alloc(9F). This parameter can be NULL if no suitable device pointer is available.

fmt

format of message to be displayed

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_dev_warn() function is a convenience wrapper that sends a message to the system console or logs using cmn_err(9F) with a level of CE_WARN. It also prefixes the message with information identifying the device if adev is not NULL.

The format should not contain any trailing newlines, as the newline will be appended by cmn_err() automatically. Unlike cmn_err(), however, no special handling of the first character of the format string is performed.

Context

This function may be called in any context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(7), audio_dev_alloc(9F), cmn_err(9F)