Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ddi_get_eventcookie(9F)

Name

ddi_get_eventcookie - retrieve a NDI event service cookie handle

Synopsis

#include <sys/dditypes.h>
#include <sys/sunddi.h>

int ddi_get_eventcookie(dev_info_t *dip, char *name,
     ddi_eventcookie_t *event_cookiep);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dev_info_t *dip

Child device node requesting the cookie.

char *name

NULL-terminated string containing the name of the event.

ddi_eventcookie_t *event_cookiep

Pointer to cookie where event cookie will be returned.

Description

The ddi_get_eventcookie() function queries the device tree for a cookie matching the given event name and returns a reference to that cookie. The search is performed by a calling up the device tree hierarchy until the request is satisfied by a bus nexus driver, or the top of the dev_info tree is reached.

The cookie returned by this function can be used to register a callback handler, unregister a callback handler, or post an event.

Return Values

DDI_SUCCESS

Cookie handle is returned.

DDI_FAILURE

Request was not serviceable by any nexus driver in the driver's ancestral device tree hierarchy.

Context

The ddi_get_eventcookie() function can be called from user and kernel contexts only.

Attributes

See attributes(7) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

attributes(7), ddi_add_event_handler(9F), ddi_remove_event_handler(9F)

Writing Device Drivers in Oracle Solaris 11.4