Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

pci_param_free(9F)

Name

pci_param_free - free resources allocated bypci_param_get()andpci_param_get_ioctl()

Synopsis

#include <sys/sunddi.h>

int pci_param_free(pci_param_t param);

Parameters

param

A handle obtained from pci_param_list() or pci_param_get_ioctl().

Description

The pci_param_free() function frees the resources allocated by pci_param_get(9F) and pci_param_get_ioctl(9F). This function must be called by the device driver after obtaining the device parameters using the param handle.

Return Values

DDI_SUCCESS

Successful completion.

Non-zero value

The param handle passed is invalid.

Context

The pci_param_free() function can be called from kernel non-interrupt context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Uncommitted

See Also

attributes(7), pci_param_get(9F), pci_param_get_ioctl(9F)