Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

bp_copyin(9F)

Name

bp_copyin - copy from a buf(9S) into a driver buffer

Synopsis

#include <sys/types.h>
#include <sys/buf.h>

int bp_copyin(struct buf *bp, void *driverbuf, offset_t offset, 
     size_t size);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

bp

Pointer to the buffer header structure to copy from.

driverbuf

Driver buffer to copy to.

offset

Offset into bp where to start copying.

size

Size of copy.

Description

The bp_copyin() function copies size bytes into the memory associated with bp to the destination driver buffer driverbuf. The offset only applies to bp.

Return Values

Under normal conditions, 0 is returned to indicate a successful copy. Otherwise, -1 is returned if bp references invalid pages.

Context

The bp_copyin() function can be called from user or kernel context only.

See Also

bp_copyout(9F), bp_mapin(9F), bp_mapout(9F), ddi_copyout(9F), buf(9S)