Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ptob(9F)

Name

ptob - convert size in pages to size in bytes

Synopsis

#include <sys/ddi.h>

unsigned long ptob(unsigned long numpages);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

numpages

Size in number of pages to convert to size in bytes.

Description

This function returns the number of bytes that are contained in the specified number of pages. For example, if the page size is 2048, then ptob(2) returns 4096. ptob(0) returns 0.

Return Values

The return value is always the number of bytes in the specified number of pages. There are no invalid input values, and no checking will be performed for overflow in the case of a page count whose corresponding byte count cannot be represented by an unsigned long. Rather, the higher order bits will be ignored.

Context

The ptob() function can be called from user, interrupt, or kernel context.

See Also

ddi_ptob(9F), btop(9F), btopr(9F)

Writing Device Drivers in Oracle Solaris 11.4