Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

kstat_delete(9F)

Name

kstat_delete - remove a kstat from the system

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>

void kstat_delete(kstat_t *ksp);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

ksp

Pointer to a currently installed kstat(9S) structure.

Description

kstat_delete() removes ksp from the kstat chain and frees all associated system resources.

Return Values

None.

Context

kstat_delete() can be called from any context.

See Also

kstat_install(9F), kstat_create(9F), kstat_named_init(9F), kstat(9S), kstat2_create(9F), kstat2_delete(9F), kstat2_install(9F)

Writing Device Drivers in Oracle Solaris 11.4

Notes

The use of the kstat_delete() function is deprecated. The function may be removed in a future release of Oracle Solaris. Use the kstat2_create() and kstat2_delete() functions instead. When calling the kstat_delete() function, the driver must not be holding that kstat's ks_lock. Otherwise, it may deadlock with a kstat reader. For more information, see the kstat2_create(9F) and kstat2_delete(9F) man pages.