Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

getmaxminor (9F)

Name

getmaxminor - get maximum minor device number

Synopsis

#include <sys/types.h>
#include <sys/mkdev.h>
#include <sys/ddi.h>
minor_t getmaxminor();

Interface Level

Architecture independent level 1 (DDI/DKI).

Description

The getmaxminor() function returns the maximum supported minor number.

Return Values

The maximum possible minor number.

Context

The getmaxminor() function can be called from user, interrupt, or kernel context.

See Also

getmajor(9F), getminor(9F), makedevice(9F)