Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

uwritec(9F)

Name

uwritec - remove a character from a uio structure

Synopsis

#include <sys/uio.h>

int uwritec(uio_t *uio_p);

Interface Level

Architecture independent level 1 (DDI/DKI)

Parameters

uio_p

Pointer to the uio(9S) structure

Description

The uwritec() function returns a character from the uio structure pointed to by uio_p and updates the uio structure. See uiomove(9F).

Return Values

The next character for processing is returned on success, and -1 is returned if uio is empty or if there is an error.

Context

The uwritec() function can be called from user, interrupt, or kernel context.

See Also

uiomove(9F), ureadc(9F), iovec(9S), uio(9S)

Writing Device Drivers in Oracle Solaris 11.4

Notes

Driver defined locks should not be held across calls to this function.