bioaligned - check alignment of buffer data
#include <sys/ddi.h> #include <sys/sunddi.h> int bioaligned(struct buf *bp, size_t align, int flags);
Pointer to the buf(9S) structure describing the original I/O request.
Power of two alignment being checked.
Determines the type of alignment being checked. Flag values supported are BIOALIGNED_BEGIN (which checks the beginning address alignment), and BIOALIGNED_END (which checks the ending address alignment).
Solaris DDI specific (Solaris DDI).
The bioaligned() function checks the alignment of memory associated with a buffer. It returns 1 if the buffer is aligned and 0 if the buffer is unaligned.
The bioaligned() function returns 1 if the buffer is aligned and 0 if the buffer is unaligned.
The bioaligned() function can be called from any context.
See attributes(7) for descriptions of the following attributes: