Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

audio_engine_get_private(9F)

Name

audio_engine_set_private, audio_engine_get_private - set or get private state for an audio engine

Synopsis

#include <sys/audio/audio_driver.h>

void *audio_engine_get_private(audio_engine_t *eng);
void audio_engine_set_private(audio_engine_t *eng, void *state)

Parameters

eng

pointer to an audio engine allocated with audio_engine_alloc(9F)

state

a private soft state structure for the device driver

Interface Level

Solaris DDI specific (Solaris DDI)

Description

The audio_engine_set_private() function stores a pointer to the driver private state for the engine in the audio engine structure.

The pointer to the private state established by audio_engine_set_private() is passed as the first argument to the engine's entry points registered in the audio_engine_ops(9S) structure.

The audio_engine_get_private() function retrieves the previously stored private state pointer.

Return Values

The audio_engine_get_private() function returns the device driver private state pointer.

Context

These functions may be called from any context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Committed

See Also

audio(4D), attributes(7), audio_engine_alloc(9F), audio_engine_ops(9S)