Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

scsi_hba_probe(9F)

Name

scsi_hba_probe - default SCSI HBA probe function

Synopsis

#include <sys/scsi/scsi.h>

int scsi_hba_probe(struct scsi_device *sd, int(*waitfunc)(void));

Interface Level

Solaris architecture specific (Solaris DDI).

Parameters

sd

Pointer to a scsi_device(9S) structure describing the target.

waitfunc

NULL_FUNC or SLEEP_FUNC.

Description

scsi_hba_probe() is a function providing the semantics of scsi_probe(9F). An HBA driver may call scsi_hba_probe() from its tran_tgt_probe(9E) entry point, to probe for the existence of a target on the SCSI bus, or the HBA may set tran_tgt_probe(9E) to point to scsi_hba_probe directly.

Return Values

See scsi_probe(9F) for the return values from scsi_hba_probe().

Context

scsi_hba_probe() should only be called from the HBA's tran_tgt_probe(9E) entry point.

See Also

tran_tgt_probe(9E), scsi_probe(9F), scsi_device(9S)

Writing Device Drivers in Oracle Solaris 11.4