Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ddi_dma_htoc(9F)

Name

ddi_dma_htoc - convert a DMA handle to a DMA address cookie

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_dma_htoc(ddi_dma_handle_t handle, off_t off,
     ddi_dma_cookie_t *cookiep);

Interface Level

This interface is obsolete. ddi_dma_addr_bind_handle(9F) or ddi_dma_buf_bind_handle(9F) should be used instead.

Parameters

handle

The handle filled in by a call to ddi_dma_setup(9F).

off

An offset into the object that handle maps.

cookiep

A pointer to a ddi_dma_cookie(9S) structure.

Description

The ddi_dma_htoc() function takes a DMA handle (established by ddi_dma_setup(9F)), and fills in the cookie pointed to by cookiep with the appropriate address, length, and bus type to be used to program the DMA engine.

Return Values

The ddi_dma_htoc() function returns:

DDI_SUCCESS

Successfully filled in the cookie pointed to by cookiep.

DDI_FAILURE

Failed to successfully fill in the cookie.

Context

The ddi_dma_htoc() function can be called from user, interrupt, or kernel context.

Attributes

See attributes(7) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Stability Level
Obsolete

See Also

attributes(7), ddi_dma_addr_bind_handle(9F), ddi_dma_addr_setup(9F), ddi_dma_buf_bind_handle(9F), ddi_dma_buf_setup(9F), ddi_dma_setup(9F), ddi_dma_sync(9F), ddi_dma_cookie(9S)

Writing Device Drivers in Oracle Solaris 11.4