net_ispartialchecksum - indicate if a packet is being scheduled for hardware checksum calculation
#include <sys/neti.h> int net_ispartialchecksum(const net_data_t net, mblk_t *mb);
Solaris DDI specific (Solaris DDI).
value returned from a successful call to net_protocol_lookup(9F).
the mblk structure holding a packet that is the subject of this query.
The net_ispartialchecksum() function looks at the fields within the mblk structure to determine if the packet contained inside contains headers with only partial checksum values. Partial checksum values are stored inside headers when the calculation of the complete checksum is being handled by the hardware.
The net_ispartialchecksum() function returns:
The network protocol does not support this function.
The packet does not contain partial checksums.
If a packet is marked for hardware checksum'ing, the following values are returned:
Complete layer 3 checksum calculated
Partial layer 3 checksum calculated
Complete layer 4 checksum calculated
Partial layer 4 checksum calculated
The net_ispartialchecksum() function may be called from user, kernel, or interrupt context.
See attributes(7) for descriptions of the following attributes: