Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

min(9F)

Name

min - return the lesser of two integers

Synopsis

#include <sys/ddi.h>

int min(int int1, int int2);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

int1

The first integer.

int2

The second integer.

Description

The min() function compares two signed integers and returns the lesser of the two.

Return Values

The lesser of the two integers.

Context

The min() function can be called from user, interrupt, or kernel context.

See Also

max(9F)

Writing Device Drivers in Oracle Solaris 11.4