Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

net_ifgroupgetnext (9F)

Name

net_ifgroupgetnext - search through the current list of firewall interface groups attached to a particular network interface

Synopsis

#include <sys/neti.h>

int net_ifgroupgetnext(net_handle_t net, phy_if_t ifp, char *prev,
char *next);

Parameters

net

value returned from a successful call to the net_protocol_lookup() function

ifp

value returned from a successful call to net_phylookup() function

prev

value of the next parameter set by the previous call to the net_ifgroupgetnext() function. The first call to the net_ifgroupgetnext() function is made by setting prev parameter to ""

next

pointer to the region of memory where the name of the next group in sequence is to be written. If the next group is not found, the next parameter is set to ""

Interface Level

Solaris DDI specific (Solaris DDI).

Description

The net_ifgroupgetnext() function searches through all firewall interface groups attached to the interface identified by the ifp parameter. To start the search, a value of "" should be passed to the prev parameter. When the next parameter is set to "", the last group attached to the interface is reached. When called successfully, the value returned is 0. When there is a failure, -1 is returned.

Return Values

The net_ifgroupgetnext() function returns -1 if there is an error, or 0 if lookup is successful. In case there are no more groups, 0 is returned and next is set to "".

Context

The net_ifgroupgetnext() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_phylookup(9F), net_protocol_lookup(9F), attributes(7)