Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ddi_dma_curwin(9F)

Name

ddi_dma_curwin - report current DMA window offset and size

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_dma_curwin(ddi_dma_handle_t handle, off_t *offp, uint_t *lenp);

Interface Level

This interface is obsolete. ddi_dma_getwin(9F) should be used instead.

Parameters

handle

The DMA handle filled in by a call to ddi_dma_setup(9F).

offp

A pointer to a value which will be filled in with the current offset from the beginning of the object that is mapped for DMA.

lenp

A pointer to a value which will be filled in with the size, in bytes, of the current window onto the object that is mapped for DMA.

Description

The ddi_dma_curwin() function reports the current DMA window offset and size. If a DMA mapping allows partial mapping, that is if the DDI_DMA_PARTIAL flag in the ddi_dma_req(9S) structure is set, its current (effective) DMA window offset and size can be obtained by a call to ddi_dma_curwin ().

Return Values

The ddi_dma_curwin() function returns:

DDI_SUCCESS

The current length and offset can be established.

DDI_FAILURE

Otherwise.

Context

The ddi_dma_curwin() function can be called from user, interrupt, or kernel context.

Attributes

See attributes(7) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Stability Level
Obsolete

See Also

attributes(7), ddi_dma_getwin(9F), ddi_dma_movwin(9F), ddi_dma_setup(9F), ddi_dma_req(9S)

Writing Device Drivers in Oracle Solaris 11.4