Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

net_kstat2_delete (9F)

Name

net_kstat2_delete - remove a kstat for a specific instance of IP from the system

Synopsis

#include <sys/types.h>
#include <sys/kstat2.h>
#include <sys/neti.h>

void net_kstat2_delete(netid_t netid, kstat2_t *ksp);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

netid

IP instance identifier.

ksp

Pointer to a currently installed kstat2(9S) structure.

Description

The net2_kstat_delete() function removes ksp from the kstat chain and frees all associated system resources. See kstat2_delete(9F) function for a complete discussion of kstat deletion.

Context

The net2_kstat_delete() function can be called from user, kernel, or interrupt context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

kstat2_create(9F), kstat2_delete(9F), net_kstat2_create(9F)