Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

sof_bypass(9F)

Name

sof_bypass - stop receiving callbacks

Synopsis

#include <sys/sockfilter.h>

void sof_bypass(sof_handle_t hdl);

Parameters

hdl

per-socket filter handle

Description

The sof_bypass() function informs the framework that the filter instance no longer wants to receive callbacks. No guarantee is made that there will not be any active callbacks when sof_bypass() returns, only that no new callbacks will be triggered.

The only callback that will triggered for a filter that has called sof_bypass() is sofop_detach(9E).

A typical use of sof_bypass() is for a filter that only needs to be active during a certain period of a socket's lifetime. Calling sof_bypass() will minimize the performance impact of the inactive filter.

Context

The sof_bypass() function can be called from any context

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/kernel
Interface Stability
Uncommitted

See Also

attributes(7), sofop_detach(9E), sof_ops(9S)