Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

usb_handle_remote_wakeup(9F)

Name

usb_handle_remote_wakeup - Enable or disable remote wakeup on USB devices

Synopsis

#include <sys/usb/usba.h>

int usb_handle_remote_wakeup(dev_info_t *dip, int cmd);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

dip

Pointer to the device's dev_info structure.

cmd

Command. Either USB_REMOTE_WAKEUP_ENABLE or USB_REMOTE_WAKEUP_DISABLE.

Description

The usb_handle_remote_wakeup() function enables or disables remote wakeup on a USB device. This call can block.

Return Values

USB_SUCCESS

Remote wakeup is successfully enabled or disabled.

USB_FAILURE

Remote wakeup is not supported by the device. An internal error occurred.

Context

May be called from user or kernel context.

Examples


    uint_t *pwrstates;

    /* Hook into device's power management.  Enable remote wakeup. */
    if (usb_create_pm_components(dip, pwrstates) == USB_SUCCESS) {
            usb_handle_remote_wakeup(dip, USB_REMOTE_WAKEUP_ENABLE);
    }
            

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
PCI-based systems
Interface Stability
Committed
Availability
system/io/usb

See Also

attributes(7), usb_create_pm_components(9F), pm_busy_component(9F), pm_idle_component(9F), pm_lower_power(9F), pm_raise_power(9F), usb_clr_feature(9F), usb_get_cfg(9F), usb_get_dev_data(9F), usb_register_hotplug_cbs(9F), usb_cfg_descr(9S)