Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

backq(9F)

Name

backq - get pointer to the queue behind the current queue

Synopsis

#include <sys/stream.h> 

queue_t *backq(queue_t *cq);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

cq

The pointer to the current queue. queue_t is an alias for the queue(9S) structure.

Description

The backq() function returns a pointer to the queue preceding cq (the current queue). If cq is a read queue, backq() returns a pointer to the queue downstream from cq, unless it is the stream end. If cq is a write queue, backq() returns a pointer to the next queue upstream from cq, unless it is the stream head.

Return Values

If successful, backq() returns a pointer to the queue preceding the current queue. Otherwise, it returns NULL.

Context

The backq() function can be called from user, interrupt, or kernel context.

See Also

queue(9S)

Writing Device Drivers in Oracle Solaris 11.4

STREAMS Programming Guide