Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

DB_BASE(9F)

Name

DB_BASE, DB_LIM, DB_REF, DB_TYPE - Data block access macros

Synopsis

#include <sys/stream.h>
#include <sys/strsun.h>

uchar_t *DB_BASE(mblk_t *mp);
uchar_t *DB_LIM(mblk_t *mp);
uchar_t DB_TYPE(mblk_t *mp);
uchar_t DB_REF(mblk_t *mp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

mp

Message block to be accessed.

Description

These macros provide compact access to public members of the datab(9S) structure associated with the specified message block.

In all cases, these macros are equivalent to directly accessing the underlying fields of the datab(9S) associated with the specified message block. Specifically:

DB_BASE(mp) is equivalent to mp->b_datap->db_base.

DB_LIM(mp) is equivalent to mp->b_datap->db_lim.

DB_TYPE(mp) is equivalent to mp->b_datap->db_type.

DB_REF(mp) is equivalent to mp->b_datap->db_ref.

Context

These functions can be called from user, kernel or interrupt context.

See Also

datab(9S), msgb(9S)

STREAMS Programming Guide