Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

net_kstat_delete(9F)

Name

net_kstat_delete - remove a kstat for a specific instance of IP from the system

Synopsis

#include <sys/types.h>
#include <sys/kstat.h>
#include <sys/neti.h>

void net_kstat_delete(netid_t netid, kstat_t *ksp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

netid

IP instance identifier.

ksp

Pointer to a currently installed kstat structure. For more information, see the kstat(9S) man page.

Description

The net_kstat_delete() function removes ksp from the kstat chain and frees all associated system resources. For a complete discussion of this function, see the kstat_delete(9F) man page.

Return Values

If successful, the net_kstat_delete() function returns a pointer to the allocated kstat. NULL is returned upon failure.

Context

The net_kstat_delete() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Obsolete

See Also

kstat_create(9F), kstat_delete(9F), net_kstat_create(9F), hook_t(9S), kstat_named(9S), net_kstat2_create(9F), net_kstat2_delete(9F)

Notes

The net_kstat_delete() function is deprecated. The function may be removed in a future release of Oracle Solaris. Use the net_kstat2_delete() function instead. For more information, see the net_kstat2_delete(9F) man page.