Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ddi_dma_coff(9F)

Name

ddi_dma_coff - convert a DMA cookie to an offset within a DMA handle.

Synopsis

#include <sys/conf.h>
#include <sys/ddi.h>
#include <sys/sunddi.h>

int ddi_dma_coff(ddi_dma_handle_t handle, ddi_dma_cookie_t *cookiep,
     off_t *offp);

Interface Level

Solaris SPARC DDI (Solaris SPARC DDI). This interface is obsolete.

Parameters

handle

The handle filled in by a call to ddi_dma_setup(9F).

cookiep

A pointer to a DMA cookie (see ddi_dma_cookie(9S)) that contains the appropriate address, length and bus type to be used in programming the DMA engine.

offp

A pointer to an offset to be filled in.

Description

The ddi_dma_coff() function converts the values in DMA cookie pointed to by cookiep to an offset (in bytes) from the beginning of the object that the DMAhandle has mapped.

The ddi_dma_coff() function allows a driver to update a DMA cookie with values it reads from its device's DMA engine after a transfer completes and convert that value into an offset into the object that is mapped for DMA.

Return Values

The ddi_dma_coff() function returns:

DDI_SUCCESS

Successfully filled in offp.

DDI_FAILURE

Failed to successfully fill in offp.

Context

The ddi_dma_coff() function can be called from user, interrupt, or kernel context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Interface Stability
Obsolete

See Also

ddi_dma_setup(9F), ddi_dma_sync(9F), ddi_dma_cookie(9S)

Writing Device Drivers in Oracle Solaris 11.4