Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

net_hook_unregister(9F)

Name

net_hook_unregister - disable a hook that was called in event processing

Synopsis

#include <sys/neti.h>

int net_hook_unregister(net_handle_t net, char *hook_name, hook_t hook);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

net

value returned from a successful call to net_protocol_register().

hook_name

hook name to be unregistered

hook

value returned from a successful call to net_hook_register(9F).

Description

The net_hook_unregister() function disables the callback hooks that were registered with the net_hook_register() function.

Return Values

If the net_hook_unregister() function succeeds, 0 is returned. Otherwise, an error indicating the problem encountered.

Context

The net_hook_unregister() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_hook_register(9F)