Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ddi_remove_event_handler(9F)

Name

ddi_remove_event_handler - remove an NDI event service callback handler

Synopsis

#include <sys/dditypes.h>
#include <sys/sunddi.h>

int ddi_remove_event_handler(ddi_registration_id_t id);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

ddi_registration_id_t id

Unique system wide registration ID return by ddi_add_event_handler(9F) upon successful registration.

Description

The ddi_remove_event_handler() function removes the callback handler specified by the registration id (ddi_registration_id_t). Upon successful removal, the callback handler is removed from the system and will not be invoked in the face of the event.

Return Values

DDI_SUCCESS

Callback handler removed successfully.

DDI_FAILURE

Failed to remove callback handler.

Context

The ddi_remove_event_handler() function can be called from user and kernel contexts only.

Attributes

See attributes(7) for a description of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Stability Level
Committed

See Also

attributes(7), ddi_add_event_handler(9F), ddi_get_eventcookie(9F)

Writing Device Drivers in Oracle Solaris 11.4

Notes

Device drivers must remove all registered callback handlers before detach(9E) processing for that device instance is complete.