Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

pci_config_setup(9F)

Name

pci_config_setup, pci_config_teardown - setup or tear down the resources for enabling accesses to the PCI Local Bus Configuration space

Synopsis

#include <sys/ddi.h>
#include <sys/sunddi.h> 

int pci_config_setup(dev_info_t *dip, ddi_acc_handle_t *handle);
void pci_config_teardown(ddi_acc_handle_t *handle);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

dip

Pointer to the device's dev_info structure.

handle

Pointer to a data access handle.

Description

pci_config_setup() sets up the necessary resources for enabling subsequent data accesses to the PCI Local Bus Configuration space. pci_config_teardown () reclaims and removes those resources represented by the data access handle returned from pci_config_setup().

Return Values

pci_config_setup() returns:

DDI_SUCCESS

Successfully setup the resources.

DDI_FAILURE

Unable to allocate resources for setup.

Context

pci_config_setup() must be called from user or kernel context. pci_config_teardown() can be called from any context.

Notes

These functions are specific to PCI bus device drivers. For drivers using these functions, a single source to support devices with multiple bus versions may not be easy to maintain.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Architecture
PCI Local Bus

See Also

attributes(7)

IEEE 1275 PCI Bus Binding