Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

bioxerror(9F)

Name

bioerror, bioxerror - indicate error in buffer header

Synopsis

#include <sys/types.h>
#include <sys/buf.h>
#include <sys/ddi.h>

void bioerror(struct buf *bp, int error);
void bioxerror(struct buf *bp, int error, b_xerror_t xerror);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

bp

Pointer to the buf(9S) structure describing the transfer.

error

Error number to be set, or zero to clear an error indication.

xerror

If error is non-zero, extended error number to be set. If error is zero, the xerror extended error number value should be B_XERR_RECOVERED or B_XERR_UNDEFINED.

Description

For bioerror(), a non-zero error value indicates that an error has occurred while processing the bp transfer. The error indication in bp is set. A subsequent call to geterror(9F) will return error.

For bioxerror(), a non-zero error value indicates that an error has occurred, with xerror as the extended error, while processing the bp transfer. The error indication in bp is set. A subsequent call to geterror(9F) will return error, and a subsequent call to getxerror(9F) will return xerror.

If error is 0, the error indication in bp is cleared. If the error indication is cleared, a subsequent call to geterror(9F) will return 0, and a subsequent call to getxerror(9F) will return either B_XERR_RECOVERED or B_XERR_UNDEFINED.

Context

bioerror() can be called from any context.

bioxerror() can be called from any context.

See Also

strategy(9E), geterror(9F), getxerror(9F), getrbuf(9F), buf(9S)