Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

net_inject_alloc(9F)

Name

net_inject_alloc - allocate a net_inject_t structure

Synopsis

#include <sys/neti.h>

net_inject_t *net_inject_alloc(const int version);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

version

must always be the symbol NETI_VERSION.

Description

The net_inject_alloc() function allocates a net_inject_t structure, returning a pointer for the caller to use.

Return Values

Upon success, net_inject_alloc() returns a pointer to the allocated net_inject_t structure. On failure, hook_alloc() returns a NULL pointer.

Context

The net_inject_alloc() function may be called from user, kernel, or interrupt context.

Attributes

See attributes(7) for descriptions of the following attributes:

ATTRIBUTE TYPE
ATTRIBUTE VALUE
Availability
system/core-os
Interface Stability
Committed

See Also

net_inject_free(9F), net_inject_t(9S)