Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ureadc(9F)

Name

ureadc - add character to a uio structure

Synopsis

#include <sys/uio.h>
#include <sys/types.h>

int ureadc(int c, uio_t *uio_p);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

c

The character added to the uio(9S) structure.

uio_p

Pointer to the uio(9S) structure.

Description

The ureadc() function transfers the character c into the address space of the uio(9S) structure pointed to by uio_p, and updates the uio structure as for uiomove(9F).

Return Values

0 is returned on success and EFAULT on failure.

Context

The ureadc() function can be called from user, interrupt, or kernel context.

See Also

uiomove(9F), uwritec(9F), iovec(9S), uio(9S)

Writing Device Drivers in Oracle Solaris 11.4

Notes

Driver defined locks should not be held across calls to this function.