Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

scsi_destroy_pkt(9F)

Name

scsi_destroy_pkt - free an allocated SCSI packet and its DMA resource

Synopsis

#include <sys/scsi/scsi.h>

void scsi_destroy_pkt(struct scsi_pkt *pktp);

Interface Level

Solaris DDI specific (Solaris DDI).

Parameters

pktp

Pointer to a scsi_pkt(9S) structure.

Description

The scsi_destroy_pkt() function releases all necessary resources, typically at the end of an I/O transfer. The data is synchronized to memory, then the DMA resources are deallocated and pktp is freed.

Context

The scsi_destroy_pkt() function may be called from user, interrupt, or kernel context.

Examples

Example 1 Releasing resources
scsi_destroy_pkt(un->un_rqs);

See Also

tran_destroy_pkt(9E), scsi_init_pkt(9F), scsi_pkt(9S)

Writing Device Drivers in Oracle Solaris 11.4