Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

max(9F)

Name

max - return the larger of two integers

Synopsis

#include <sys/ddi.h>

int max(int int1, int int2);

Interface Level

Architecture independent level 1 (DDI/DKI).

Parameters

int1

The first integer.

int2

The second integer.

Description

The max() function compares two signed integers and returns the larger of the two.

Return Values

The larger of the two numbers.

Context

The max() function can be called from user, interrupt, or kernel context.

See Also

min(9F)

Writing Device Drivers in Oracle Solaris 11.4