Go to main content

man pages section 9: DDI and DKI Kernel Functions

Exit Print View

Updated: Wednesday, July 27, 2022
 
 

ldi_ev_remove_callbacks(9F)

Name

ldi_ev_remove_callbacks - remove all callbacks for a given callback ID

Synopsis

#include <sys/sunldi.h>

int ldi_ev_remove_callbacks(ldi_ev_callback_id_t id);

Interface Level

Solaris DDI specific (Solaris DDI)

Parameters

ldi_ev_callback_id_t id

An opaque data structure returned on successful calls to ldi_ev_register_callbacks(9F).

Description

The ldi_ev_remove_callback() function unregisters any callbacks that were registered via ldi_ev_register_callbacks(9F). Once this function returns successfully, the callback ID is no longer valid.

The finalize and notify callbacks exist independently of the LDI handle and are not automatically removed when the LDI handle is closed. The layered driver removes these callbacks via ldi_ev_remove_callbacks()() when the callbacks are no longer needed. The LDI framework may panic the system if the entity registering the callback (a dev_t, dip or module) no longer exists on the system and the callbacks have not been unregistered.

Return Values

The return values for this function are:

LDI_EV_SUCCESS

Callback(s) removed successfully.

LDI_EV_FAILURE

Failed to remove callback(s).

Context

This function can be called from user and kernel contexts only.

See Also

ldi_ev_get_cookie(9F), ldi_ev_register_callbacks(9F)