automountd - autofs mount/unmount daemon
automountd [-Tvn] [-D name=value]
automountd is an RPC server that answers file system mount and unmount requests from the autofs file system. It uses local files or name service maps to locate file systems to be mounted. These maps are described with the automount(1M) command.
If automount finds any non-trivial entries in either the local or distributed automount maps and if the daemon is not running already, the automountd daemon is automatically invoked by automount(1M). automountd enables the svc:/network/nfs/nlockmgr service (lockd(1M)), and the svc:/network/nfs/status service (statd(1M)), if NFS mounts need to be done.
The automountd service is managed by the service management facility, smf(5), under the service identifier:
Administrative actions on this service, such as enabling, disabling, or requesting restart, can be performed using svcadm(1M). The service's status can be queried using svcs(1). If it is disabled, it is enabled by automount(1M) unless the application/auto_enable property is set to false.
Values for parameters for automountd are stored in SMF and manipulated using sharectl(1M). The following are the supported parameters.
Verbose mode. Causes status messages to be logged to:
See smf(5). The default value is FALSE. Equivalent to the –v option.
Turn on or off browsing for all autofs mount points. The default value is OFF. Equivalent to the –n option.
Expands each RPC call and logs it to:
See smf(5). The default value, 0, turns off such tracing. Starting with 1, with each higher value, the verbosity of trace output increases. This property is equivalent to the –T option.
Environment variables. You can specify multiple name =value pairs with a comma separator. If there is more than one value for a name, use the double forward slash to indicate that. See EXAMPLES. There are no environment variable settings supplied. This property is equivalent to the –D option.
All the above parameters can be changed using the sharectl(1M) command.
The following options are supported:
Assign value to the indicated automount map substitution variable. These assignments cannot be used to substitute variables in the master map auto_master.
Turn off browsing for all autofs mount points. This option overrides the -browse autofs map option on the local host.
Trace. Expand each RPC call and display it on the standard output.
Verbose. Log status messages to the console.
See largefile(5) for the description of the behavior of automountd when encountering files greater than or equal to 2 Gbyte ( 231 bytes).
The following command turns on verbose mode, causing status messages to be logged to the location specified in “SMF Management,” above. See that section for a description of the properties specified in this and following examples.
# sharectl set -p automountd_verbose=true autofsExample 2 Turning on Browsing for Mount Points
The following command turns on browsing for all autofs mount points.
# sharectl set -p nobrowse=off autofsExample 3 Specifying and Displaying Environment Variables
The following commands set and display the value for an environment variable named DAY.
# sharectl set -p environment=DAY=TUES autofs % sharectl get -p environment autofs environment=DAY=TUES
The following command sets multiple parameters for an environment variable. The subsequent command displays the result.
# sharectl set -p environment=DAY=TUES,TIME=NOON autofs % sharectl get -p environment autofs environment=DAY=TUES,TIME=NOON
The following command set multiple values for name that is assigned to an environment variable. The subsequent command displays the result.
# sharectl set -p environment=DAY=MON\\,TUE,TIME=NOON autofs % sharectl get -p environment autofs environment=DAY=MON\,TUE,TIME=NOON
Master map for automounter.
See attributes(5) for descriptions of the following attributes: