rmvolmgr - HAL-aware removable volume manager
The rmvolmgr command is a volume manager that can automatically mount and unmount removable media and hot-pluggable storage. The default mount point is /media.
rmvolmgr is one of a number of Hardware Abstraction Layer (HAL)-aware tools that are shipped with the Solaris operating system. See hald(1M).
Multiple instances of rmvolmgr can be run simultaneously. A system instance of rmvolmgr runs by default as a service management facility (SMF) service (see smf(5)). Its fault management resource identifier (FMRI) is:
You can run your own instance of rmvolmgr by adding it to the .xinitrc file or a similar session startup script. In such a case, the system rmvolmgr instance will not manage volumes that belong to you, the owner of the startup script. For example, a user logged on to the workstation console (/dev/console) who invokes his own instance of rmvolmgr will own locally connected devices, such as CD-ROM drives and devices connected to the local USB or FireWire ports.
In addition to mounting volumes under /media, rmvolmgr also creates legacy symbolic links under /cdrom and /rmdisk.
rmvolmgr also provides backwards compatibility with CDE removable media interfaces by maintaining notification files under /tmp/.removable. This functionality can be disabled by using the –c option.
The –c and –n options can also be specified as SMF properties. See “Examples.”
The following options are supported:
Disable CDE compatibility.
Display help information and exit.
Do not create legacy mountpoint symbolic links.
Invoke in system instance mode.
The following svccfg(1M) command and subcommands use SMF properties to set the –c and –n options.
example# svccfg svc:> select rmvolmgr svc:/system/filesystem/rmvolmgr> listprop rmvolmgr/* rmvolmgr/legacy_mountpoints boolean true rmvolmgr/cde_compatible boolean true svc:/system/filesystem/rmvolmgr> setprop \ rmvolmgr/legacy_mountpoints=false svc:/system/filesystem/rmvolmgr> setprop rmvolmgr/cde_compatible=false svc:/system/filesystem/rmvolmgr> exit example#
See attributes(5) for descriptions of the following attributes: