set_nodedesc.sh - Set/View Node Description String for Infiniband Host Controller Adapters (HCA)s
set_nodedesc.sh set_nodedesc.sh -N <CommonString> set_nodedesc.sh -H <HCAString> -G GUID set_nodedesc.sh -H <HCAString> -G GUID -N <CommonString> set_nodedesc.sh -v
SET_NODEDESC.SH(1M) SET_NODEDESC.SH(1M) NAME set_nodedesc.sh - Set/View Node Description String for Infiniband Host Controller Adapters (HCA)s SYNOPSIS set_nodedesc.sh set_nodedesc.sh -N <CommonString> set_nodedesc.sh -H <HCAString> -G GUID set_nodedesc.sh -H <HCAString> -G GUID -N <CommonString> set_nodedesc.sh -v DESCRIPTION The set_nodedesc.sh utility can be used to set or view Node descrip- tion strings for InfiniBand(IB) Host Controller Adapters(HCA). The node description string can consist of two parts : 1. Node Description String common to all HCAs. 2. Node Description String specific to an HCA. The complete Node Description string will be : <CommonNodeDescriptionString><HCANodeDescriptionString> The common Node Description String is used if no HCA specific Node descr- iption string is set. The Node Descriptor string from the HCA firmware will be used if common node descriptor is not set. set_nodedesc.sh called without arguments, sets the common node descrip- tor string to the hostname(1) of the system. The common Node descriptor string can be set to a string other than the hostname(1) using the -N option. The HCA specific Node Description String can be set using the -H and -G option. The Global Unique IDentifier (GUID) specified with -G identi- fies the HCA to set the HCA specific Node Description string. The options -H and -G can be combined together with -N, to specify the com- mon Node description String. The -v option can be used to view the Node descriptors for all HCAs on the system. It will fail if no node description has been written on the system previously. EXAMPLES 1. Set Node descriptor string to hostname(1) for all HCAs: set_nodedesc.sh 2. Set Node descriptor string to string "test": #set_nodedesc.sh -N "test" 3. Setting the HCA specific Node Description for HCA with GUID 0x0002c903000008d0 to " hca_test" : #set_nodedesc.sh -H " hca_test" -G 0x0002c903000008d0 4. Setting the HCA specific Node Description for HCA with GUID 0x0002c903000008d0 to " hca_test1" and set the common node descriptor to "test1" : #set_nodedesc.sh -H " hca_test" -G 0x0002c903000008d0 -N "test1" 5. Read all Node descriptiors : #set_nodedesc.sh -v See Also ATTRIBUTES See attributes(5) for descriptions of the following attributes: +---------------+-----------------------+ |ATTRIBUTE TYPE | ATTRIBUTE VALUE | +---------------+-----------------------+ |Availability | network/open-fabrics | +---------------+-----------------------+ |Stability | Pass-through volatile | +---------------+-----------------------+ NOTES This software was built from source available at https://java.net/projects/solaris-userland. The original community source was downloaded from ['http://download.oracle.com/otn- pub/oss/networking/libsif-1.0.tar.gz', 'https://www.openfab- rics.org/downloads/ibutils/ibutils-1.5.7-0.2.gbd7e502.tar.gz', 'https://www.openfabrics.org/downloads/libibverbs/libib- verbs-1.1.8.tar.gz', 'https://www.openfabrics.org/down- loads/libmlx4/libmlx4-1.0.6.tar.gz', 'https://www.openfabrics.org/down- loads/libsdp/libsdp-1.1.108-0.15.gd7fdb72.tar.gz', 'https://www.open- fabrics.org/downloads/management/infiniband-diags-1.6.5.tar.gz', 'https://www.openfabrics.org/downloads/management/libib- mad-1.3.12.tar.gz', 'https://www.openfabrics.org/downloads/manage- ment/libibumad-1.3.10.2.tar.gz', 'https://www.openfabrics.org/down- loads/management/opensm-3.3.19.tar.gz', 'https://www.openfab- rics.org/downloads/perftest/perftest-1.3.0-0.42.gf350d3d.tar.gz', 'https://www.openfabrics.org/downloads/qperf/qperf-0.4.9.tar.gz', 'https://www.openfabrics.org/downloads/rdmacm/librdmacm-1.0.21.tar.gz', 'https://www.openfabrics.org/downloads/rds-tools/rds- tools-2.0.4.tar.gz'] Further information about this software can be found on the open source community website at http://www.openfabrics.org/. USER COMMANDS 21 Oct 2015 SET_NODEDESC.SH(1M)