ramdiskadm - administer ramdisk pseudo device
/usr/sbin/ramdiskadm -a name size [g | m | k | b]
/usr/sbin/ramdiskadm -d name
The ramdiskadm command administers ramdisk(7D), the ramdisk driver. Use ramdiskadm to create a new named ramdisk device, delete an existing named ramdisk, or list information about existing ramdisks.
Ramdisks created using ramdiskadm are not persistent across reboots.
The following options are supported:
Create a ramdisk named name of size size and its corresponding block and character device nodes.
name must be composed only of the characters a-z, A-Z, 0-9, _ (underbar), and - (hyphen), but it must not begin with a hyphen. It must be no more than 32 characters long. Ramdisk names must be unique.
The size can be a decimal number, or, when prefixed with 0x, a hexadecimal number, and can specify the size in bytes (no suffix), 512-byte blocks (suffix b), kilobytes (suffix k), megabytes (suffix m) or gigabytes (suffix g). The size of the ramdisk actually created might be larger than that specified, depending on the hardware implementation.
If the named ramdisk is successfully created, its block device path is printed on standard out.
Delete an existing ramdisk of the name name. This command succeeds only when the named ramdisk is not open. The associated memory is freed and the device nodes are removed.
You can delete only ramdisks created using ramdiskadm. It is not possible to delete a ramdisk that was created during the boot process.
Without options, ramdiskadm lists any existing ramdisks, their sizes (in decimal), and whether they can be removed by ramdiskadm (see the description of the –d option, above).
# ramdiskadm -a mydisk 2m /dev/ramdisk/mydiskExample 2 Listing All Ramdisks
# ramdiskadm Block Device Size Removable /dev/ramdisk/miniroot 134217728 No /dev/ramdisk/certfs 1048576 No /dev/ramdisk/mydisk 2097152 Yes
ramdiskadm returns the following exit values:
An error occurred.
See attributes(5) for descriptions of the following attributes:
The abilities of ramdiskadm and the privilege level of the person who uses the utility are controlled by the permissions of /dev/ramdiskctl. Read access allows query operations, for example, listing device information. Write access is required to do any state-changing operations, for example, creating or deleting ramdisks.
As shipped, /dev/ramdiskctl is owned by root, in group sys, and mode 0644, so all users can do query operations but only root can perform state-changing operations. An administrator can give write access to non-privileged users, allowing them to add or delete ramdisks. However, granting such ability entails considerable risk; such privileges should be given only to a trusted group.