halt, poweroff - stop the processor
The halt and poweroff utilities write any pending information to the disks and then stop the processor. The poweroff utility has the machine remove power, if possible.
The halt and poweroff utilities normally log the system shutdown to the system log daemon, syslogd(1M), and place a shutdown record in the login accounting file /var/adm/wtmpx. These actions are inhibited if the –n or –q options are present.
The following options are supported:
Force a system crash dump before rebooting. See dumpadm(1M) for information on configuring system crash dumps.
Suppress sending a message to the system log daemon, syslogd(1M), about who executed halt.
Prevent the sync(1M) before stopping.
Quick halt. No graceful shutdown is attempted.
History of user access and administration information.
See attributes(5) for descriptions of the following attributes:
The halt and poweroff utilities do not cleanly shutdown smf(5) services, execute the scripts in /etc/rcnum.d, or execute shutdown actions in inittab(4). To ensure a complete shutdown of system services, use shutdown(1M) or init(1M) to reboot a Solaris system.