gcore [-pgF] [-o filename] [-c content] process-id...
The gcore utility creates a core image of each specified process. By default, the name of the core image file for the process whose process ID is process-id is core.process-id.
The following options are supported:
Produces core image files with the specified content. The content description uses the same tokens as in coreadm(1M). The –c option does not apply to cores produced due to the –p or –g flags.
Force. Grabs the target process even if another process has control.
Produces core image files in the global core file repository with the global content as configured by coreadm(1M). The command fails if the user does not have permissions to the global core file repository.
Substitutes filename in place of core as the first part of the name of the core image files. filename can contain the same tokens to be expanded as the paths in coreadm (1M).
Produces a core image file in the process-specific location with the process-specific content for each process as configured by coreadm(1M). The command fails if the user does not have permissions to the per-process core file repository.
The following operand is supported:
Caution should be exercised when using the –F flag. Imposing two controlling processes on one victim process can lead to chaos. Safety is assured only if the primary controlling process, typically a debugger, has stopped the victim process and the primary controlling process is doing nothing at the moment of application of the proc tool in question.
The following exit values are returned:
On failure, such as non-existent process ID.
See attributes(5) for descriptions of the following attributes:
The command syntax is Committed. The Output Formats are Uncommitted.
gcore is unaffected by the setrlimit(2) system call using the RLIMIT_CORE value.