updatehome reads the user's minimum-label copy and link-control files (.copy_files and .link_files). These files contain a list of files to be copied and symbolically linked from the user's minimum-label home directory to the user's home directory at the current label.
By default, the minimum user label is specified in label_encodings(4), and can be explicitly specified in user_attr(4). When created using txzonemgr(1M), the public zone is assigned the default minimum label, and is configured as a multilevel NFS server. An authorized administrator in the public zone can use the share(1M) command to export home directories, so that they can be mounted in read-only mode by higher-level zones. Additional zones created by means of txzonemgr(1M) are configured with an automount(1M) entry that mounts the public zone's home directories at /zone/public/home.
If the user's minimum home directory has been shared in this fashion, a user can run the updatehome command in higher-level zones, either manually or by executing it in a startup file. For example, the user probably wants a symbolic link to such files as .profile, .login, .cshrc, .exrc, .mailrc, and ~/bin. The updatehome command provides a convenient mechanism for accomplishing this symlink. The user can add files to those to be copied (.copy_files ) and to those to be symbolically linked (.link_files).
Replace existing home-directory copies at the current label. The default is to skip over existing copies.
Ignore errors encountered. The default aborts on error.
Replace existing home-directory copies or symbolic links at the current label. This option implies options –c and –s. The default is to skip over existing copies or symbolic links.
Replace existing home-directory symbolic links at the current label. The default is to skip over existing symbolic links.
Upon success, updatehome returns 0. Upon failure, updatehome returns 1 and writes diagnostic messages to standard error.
The files that are listed in .copy_files can be modified at every user's label.
.cshrc .mailrc .mozilla/bookmarks.htmlExample 2 A Sample .link_files File
The files that are listed in .link_files can be modified at the lowest label. The changes propagate to the other labels that are available to the user.
~/bin .mozilla/preferences .xrc .rhostsExample 3 Updating the Linked and Copied Files
The .copy_files and .link_files were updated by the user at the minimum label. At a higher label, the user refreshes the copies and the links. No privileges are required to run the command.
% updatehome -r
List of files to be copied
List of files to be symbolically linked
See attributes(5) for descriptions of the following attributes:
The functionality described on this manual page is available only if the system is configured with Trusted Extensions.