userattr [-v] attribute_name [user]
The userattr command prints on standard output the first value found for the attribute attribute_name. If user is not specified, the user is taken from the real user ID of the process. Attribute names are those found defined in user_attr(4) and prof_attr(4) . Use the profiles(1) command for the profiles assigned to a user. Use the auths(1) command for the authorizations assigned to a user. The order of search is the user's user_attr entry followed by the user's profiles.
If the attribute, attribute_name, is not assigned to the user, and for any errors, userattr returns a non-zero exit code. Otherwise, userattr returns a zero exit code.
The –v option additionally prints where the attribute was found.
example% userattr lock_after_retries root no
The following exit values are returned:
An error occurred.
See attributes(5) for descriptions of the following attributes:
The exit code is Committed. The output for the –v option is Not-an-Interface.