With no arguments, groups displays the groups to which you belong; else it displays the groups to which the user belongs. Each user belongs to a group specified in the password file /etc/passwd and possibly to other groups as specified in the file /etc/group . If you do not own a file but belong to the group which it is owned by then you are granted group access to the file.
See attributes(5) for descriptions of the following attributes:
This command is obsolete and will be removed in a future release of Oracle Solaris. See groups(1) for an alternate implementation of this command.