pkgparam [-v] [-d device] [-R root_path] pkginst [param]...
pkgparam -f filename [-v] [param]...
pkgparam displays the value associated with the parameter or parameters requested on the command line. The values are located in either the pkginfo(4) file for pkginst or from the specific file named with the –f option.
One parameter value is shown per line. Only the value of a parameter is given unless the –v option is used. With this option, the output of the command is in this format:
parameter1='value1' parameter2='value2' parameter3='value3'
If no parameters are specified on the command line, values for all parameters associated with the package are shown.
Options and arguments for this command are:
Specify the device on which a pkginst is stored. It can be a directory pathname or the identifiers for a tape or removable disk (for example, /var/tmp or /dev/dsk/c1d0s0). The special token spool may be used to represent the default installation spool directory (/var/spool/pkg).
Read filename for parameter values.
Defines the full path name of a subdirectory to use as the root_path. All files, including package system information files, are relocated to a directory tree starting in the specified root_path.
Verbose mode. Display name of parameter and its value.
Defines a specific package instance for which parameter values should be displayed.
Defines a specific parameter whose value should be displayed.
If parameter information is not available for the indicated package, the command exits with a non-zero status.
An error occurred.
See attributes(5) for descriptions of the following attributes:
With the –f option, you can specify the file from which parameter values should be extracted. This file should be in the same format as a pkginfo(4) file. For example, such a file might be created during package development and used while testing software during this stage.
Package commands are largefile(5)-aware. They handle files larger than 2 GB in the same way they handle smaller files. In their current implementations, pkgadd(1M), pkgtrans(1) and other package commands can process a datastream of up to 4 GB.